
By Dr Derek Peacock

Presenter
Presentation Notes
This presentation is an introduction to HTML, and most of the code is based on versions of HTML prior to HTML5.  I have only labelled the slide HTML5 when it contains code which is new in HTML5 and not in earlier versions. Most slides contain code which has been part of the HTML language for many versions, only slides 3-5 contain HTML5 specific information.

This presentation shows how HTML can be used to create a web page containing text, images and hyperlinks which are the basic elements in any web page. 



HTML5 is a “Game Changer” new features 
include:-
 New HTML tags
 Graphics Hardware Support
 Native Multimedia Support
 Form Data Validation
 Offline Working
 Drag & Drop
 Messaging Support

Presenter
Presentation Notes
HTML is a language developed specifically to create web pages, and it essentially takes the textual content of a web page and places tags around various parts of the page to signify (or mark up) that this portion of text is a heading, a paragraph, a table or a list.  HTML5 is the latest and greatest version of this language and is only fully supported by the latest browsers.  It does however have so many advantages that I believe it is the best version to use for beginners as it is easier to use, and easier to understand.

For web developers it provides very important advantages such as multimedia support, support for graphics cards, data validation in forms and much else to make a web developers job so much easier than before.  Unfortunately although Dreamweaver CS5 supports HTML5, the support is not complete yet.



Presenter
Presentation Notes
To create a new HTML5 page you must use File -> New on the menus, and then select Blank Page, Layout None and DocType: HTML5

Although it is possible to create a new html page from Dreamweaver’s Start screen, unless the correct preferences have been set, that page will not be an HTML5 page.  Preferences can be changed by using Edit -> Preferences -> New Document.



<!DOCTYPE HTML>
<html>

<head>
<meta charset="utf-8">
<title>My 1st Page</title>

</head>

<body>
</body>

</html>

Presenter
Presentation Notes
A new blank HTML5 page contains the code shown above.  The first DOCTYPE tag declares that this html page is an HTML5 page.  Previous versions of HTML had much more complicated DOCTYPE declarations. This is followed by a start <html> tag which is closed at the end of the document.  HTML tags mostly come with start and end tags.  Inside the HTML tags is the head of the document and the body of the document as illustrated on the next slide.



<html> start tag
</html> end tag

<head> start tag
</head> end tag

<body> start tag
</body> end tag

html

head

body

Presenter
Presentation Notes
All web pages start with an <html> tag and end with a </html> tag.  Inside of which there is a head and body region surrounded by start and end tags.



<head>
<meta charset="utf-8">
<title>

The Page Title
</title>
<link href=“mystyles.css”>

</head>

<meta>

<title>

<link>

Presenter
Presentation Notes
The head region of an HTML page contains the page title.  All pages should be given a unique title.  The title is displayed to the user in the web page tab at the top of the page. There are a number of meta tags, the most important is the one that defines which character set is being used.  For European languages utf-8 is a typical choice. For languages with a large number of letters or symbols, other character sets are available.

The head region is also where style sheets can be linked to the html page.  The style sheets will then control how the page looks in terms of fonts used, colours, spacing and positioning of elements in the page.



<body>
<h1>My First Heading</h1>
<p>My first paragraph</p>
<p>My second paragraph</p>

</body>

Presenter
Presentation Notes
The body of an HTML page contains all the page contents that the user will see when the page is displayed.  In design view, textual content can just be typed in (only press return or enter, at the end of a paragraph or heading) and then the format of the text changed by selecting it, and then going to the Properties panel at the bottom of the Dreamweaver main window, and selecting Heading 1 for example. Level 1 headings are surrounded by <h1> tags, and paragraphs by <p> tags.



Presenter
Presentation Notes
In Visual Studio you can right click on an html file and view it in the page inspector.  You can see Design View which shows roughly how the page will look, and Code View which shows the HTML code.  The window can also be Split to show both at the same time.  



<ol>
<li>

List Item 1
</li>
<li>

List Item 2
</li>
<li>

List Item 3
</li>

</ol>

Code View Design View

Presenter
Presentation Notes
Lists can be created most easily in design view.  Type in each item in the list and then press enter (return key).  Then select all the items in the list and select ordered or unordered list in the Properties panel at the bottom of the main window.  The code shown will be automatically written for you.

The whole list is inside <ol> (0rdered list) or <ul> (unordered list) tags.  Each item in the list is inside <li> tags.  
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Presentation Notes
Lists are typically used to create menu items or navigation links by selecting each list item in design view and using Insert Hyperlink, or just entering a # symbol into the link text box in the Properties panel. The result in code is that each list item is wrapped inside an anchor or <a> tag.  The tag has a reference to the destination of the hyperlink.  This would normally be the url of another web page, the # symbol just stands as a link placeholder.




Presenter
Presentation Notes
In order to see how a web page might look, it is common practice to use the Lorum Ipsum web sight to generate placeholder text that can be pasted into a web page in design view in order to give the appearance of a completed page. Click on the Generate Lorem Ipsum button and then copy however many paragraphs of latin text you need to mock up the web page.



Presenter
Presentation Notes
Having pasted in two paragraphs of Lorem Ipsum text in place of the existing paragraphs, it is best to turn Word Wrap off so that this text does not obscure the code listing. There are a number of useful setting in the left margin of Dreamweaver’s main window, including indent and outdent, and the ability to add comments to the code.



Presenter
Presentation Notes
Most web pages contain images, and it is common practice when developing a web page to put image placeholders in the page to start with.  This just helps designers decide what size of image they want, and where on the page they want it.  The actual image can be chosen later and substituted for the placeholder.  This web site provides placeholders of any size, simply copy the code, paste it into the web page code and then modify the size.



Presenter
Presentation Notes
The code to place a real image into a web page is almost the same as the code shown above.  In place of the url for Placehold.it would be either the url of an external image, or the filename of an image inside the web site. To place an image in the web page use Insert -> Image from the menus or from the Insert panel at the top right hand corner of Dreamweaver.



• Add Existing Image
• Drag and Drop Image
• Add alt attributes

Presenter
Presentation Notes
After selecting Insert -> Image from the menus the Select Image dialog appears.  Only three image formats are allowable in web pages

Gif – limited colours, but can be used to create simple animations
Png – unlimited colours and can handle transparency
Jpeg – unlimited colours and compressed for small file size

If you select and image outside the web site Dreamweaver will prompt you to copy it inside the web site.  All images should be inside the web site so that wen the web site is published the images are still accessible.



Presenter
Presentation Notes
After an image has been selected, you will be prompted for an alternative text description of the image.  This should always be filled in to provide accessibility for people that are unable to see the image.  The alternative text can be read to them by screen readers. Also if for some reason the image cannot be found the alternative text tells people what image is missing.




1. Using Frame Sets
2. Using Tables
3. Using CSS

1. Browser compatibility
2. Improving Accessibility
3. Improving Usability

Presenter
Presentation Notes
Over the years the way web developers have positioned elements on a web page has changed.  In the early days a web page was broken down into Frames, with each frame being in a separate file.  This however did not provide sufficient flexibility and was superseded by using tables. The problem with tables is that they need a lot of code, and maintaining such code is difficult. Tables and Frames both could not be changed easily, requiring every web page to be altered individually.

The current approach is based on CSS, as it has the advantage of reduced code, and increased flexibility.  One change in a style sheet can immediately affect all the web pages in the web site. Unfortunately as CSS was not developed to position elements on a page, and therefore using it for that purpose is not easy.  Once a style sheet has been devised however it can easily be changed and adapted for future pages.

What makes matters more difficult is that each browser interprets CSS in different ways, and some browsers (in particular IE) do not implement parts of the CSS language. It therefore takes a lot of effort to use CSS and produce the same structure in the different browsers.

HTML5 has introduced a lot of features to improve accessibility for those whose eyesight is poor, and who rely on screen readers to “see” the page. HTML5 also contains improvements that make web pages more useable.



 Simplicity
 Flexibility
 Fluidity
 Bullet Proof
 Progressive enhancement

 Smart Phones, Tablets, Game Consoles, 
Internet TVs, Notebooks, etc.

Presenter
Presentation Notes
Best practice in web development currently aims at producing pages that are fluid and flexible, and pages that will not break down if the page size is altered.  The latest versionb of CSS has facilities for detecting page size and device, and responding to that by creating different pages to suite the different devices.

To cope with the problem that older versions of the browsers do not understand the latest versions of HTML and CSS, web developers aim to produce pages that will work on any browser, but will look much better in the more modern browsers.  This is referred to as Progressive Enhancement.



 Pros
◦ Can be quicker and easier
◦ Lets you see how it might look immediately
◦ Do not need to understand the code
◦ Do not need to remember the tags

 Cons
◦ Can lead to very difficult to maintain code
◦ Can lead to inflexible code
◦ You will not fully understand how the page works
◦ You will not have full control over your pages

Presenter
Presentation Notes
Visual Design can make development quicker and easier.  It does however have limitations, in particular it can write code that is not correct, or not the best way of doing something.  If you do not understand how the code works, it can be very difficult to sort that out.

I plan to focus on using Design View to do what it can do quickly and easily, but at the same time to make sure that you can understand the code that has been written, and can if need be alter that code.  There are in fact some aspects of a web page that are quicker and easier to do in code view rather than design view.



 Dreamweaver  CC (not free)
 Visual Studio 2013 Community (free)
 Text Editors (notepad++)

 Firefox 37 (Firebug)
 Internet Explorer 11 (IE Tester)
 Chrome 42

Presenter
Presentation Notes
Although these presentations are based on Dreamweaver CS5.5, there are other development tools that can do a similar job.  In particular Visual Studio Web Developer Express 2010 from Microsoft is on a par with Dreamweaver, and can be used to edit most of the web pages produced in Dreamweaver. Visual Studio has the advantage that is freely downloadable whereas the cheapest copy of Dreamweaver costs £100 if you are a student, and £400 otherwise.

Web pages can however be produced using nothing more than a simple text editor like Notepad, or Notepad+ which are again freely available software applications. A good alternative are HTML Editors like BlueGriffon in which you can edit in code and design view.

In order to view HTML5 web pages you do need an up to date browser. For web developers the best Browsers are Firefox and Chrome, the worst choice is Internet Explorer.  Only version 9 of Internet Explorer can be used to view HTML5, whereas Firefox 3.6 and above was HTML5 capable.



 Introducing HTML5 by Bruce Lawson
 Handcrafted CSS by Dan Cederholm

Presenter
Presentation Notes
Teach Yourself Dreamweaver is the best choice if you want a reference book on how to do something in Dreamweaver.  The book is organised into one hour lessons, and it is easy to find what you are looking for.  However it does not have much on HTML3 and CSS3, and does not discuss the best approach to structuring and styling web pages

Introducing HTML5 is a short but excellent book to get you started in using HTML5.  Similarly the Handcrafted CSS discusses how best to structure and style pages to produce pages that a both fluid and bullet proof. There are nicely illustrated examples of how to best use css.
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